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Objectives 
 
Upon completion of this section, you will: 
 

 Have an overview of BEN, BEN Financials and BEN Buys 

 Know the desktop requirements for BEN Financials  

 Know how to customize your ‘Applications Navigator’ 

 Understand how to research invoice information 

 Know where to go for assistance when necessary 

 Understand how to log off from BEN Financials 
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Overview of BEN  

Business Enterprise Network (BEN) 

Penn’s business and financial management systems which includes 

 Web-enabled applications and tools 

 Support structure 

Desktop Configuration 

Consistent with current University standards  

http://www.finance.upenn.edu/ben/benfin/desktop_req/ 

 Local Support Providers (LSP’s)  

http://www.upenn.edu/computing/view/support/staff.html 

 List of primary computer support assigned by Center and by Department  

Access/Security 

Penn eForms 

http://www.upenn.edu/computing/da/eforms/    

Important Web Addresses 

U@Penn Portal 

http://medley.isc-seo.upenn.edu/penn_portal/u@penn.php 

 Access to a wide variety of University web sites and information including those listed below 

BEN Financials Homepage   

http://benapps.isc-seo.upenn.edu 

 Access to BEN Financials, BEN Deposits, and BEN Reports 

Business Enterprise Network   

http://www.finance.upenn.edu/ben 

 News, Calendar, BEN Reps, BEN Knows, Frequently Asked Questions, Support Information, etc. 

Financial Training Department Web Page   

http://www.finance.upenn.edu/ftd/ 

 Information regarding courses offered, register for training, view the Bottom Line Newsletter, 

etc. 

Audit and Compliance Web Page   

http://www.upenn.edu/audit/ 

 Information on controls, compliance mechanisms, and technologies to manage risk as well as 

providing guidance on the stewardship of University resources 

Responsibility Center Management (RCM) 

http://www.finance.upenn.edu/comptroller/rcm/index.shtml 

 Information about BEN Financials Reports, Fund Aggregations & Object Code Aggregations, etc. 

http://www.finance.upenn.edu/ben/benfin/desktop_req/
http://www.upenn.edu/computing/view/support/staff.html
http://www.upenn.edu/computing/da/eforms/
http://medley.isc-seo.upenn.edu/penn_portal/u@penn.php
http://benapps.isc-seo.upenn.edu/
http://www.finance.upenn.edu/ben
http://www.finance.upenn.edu/ftd/
http://www.upenn.edu/audit/
http://www.finance.upenn.edu/comptroller/rcm/index.shtml
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Overview of BEN (continued) 

Need Help?  

  Dial 6-HELP (6-4357 or 215/746-4357) 

 Enter your two-digit School or Center code 

 BEN Helps is available 9:00 a.m. to 5 p.m. Monday through Friday 

 BEN Knows 

http://www.finance.upenn.edu/benknows/ 

 Browse and search for possible solutions to your BEN Financials and BEN Reports questions 

Penn eForms 

Penn eForms are required for entry to most University financial systems. These eForms should be 

processed promptly to ensure system access following training. If an eForm has not been processed 

within two months or more of attending a training course, you will be required to repeat the 

course to obtain access. 

 If you need your BEN Financials password reset call 8-1099.    

 

http://www.finance.upenn.edu/benknows/
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Glossary of Terms  
 

Attachment 

Attachments are additional records (documents) that apply to the record being viewed. There are two 
types of attachments: 

a. Notes - Additional descriptive information about your requisition sent to the approver, buyer, 

receiver or supplier along with your purchase order. The attachment may take the form of a 
URL or text.  

b. Scanned image of an invoice or a C-368 form.  
 

Block 
Each window consists of one or more blocks.  All required fields in a block must be completed before 

you can move to the next block. 
 

Buyer  

The individual who creates the actual purchase order; this would be the PO Manager. 
 

Click  
Quickly press and release a mouse button while the mouse pointer is on a particular item.  

 

Deliver-To Location  

The location where goods or services are to be delivered by the supplier.  The default deliver-to location 
can be changed by you in the My Profile page.  This default location is used on all your requisitions, 

but you can change the deliver-to information manually on any requisition or any item(s) on a 
requisition.   

 

Desktop 

The part of the computer monitor that displays where your work takes place, a.k.a. your screen. 
 

Double-click  

Rapidly click a mouse button twice while the mouse pointer is on a particular item.  
 

Folders 
Refers to the custom preferences which allow you to determine what columns (fields) appear in your 

view of the data. 
 

Holds 
  

Invoice Hold 
This is the hold placed on PO invoices for the following reasons:   Finally Closed PO Hold; Items Not 

Ordered Hold; Maximum Shipment Hold; Quantity Ordered Hold; and Quantity Received Hold. C-

forms are placed on hold for the following reasons: incomplete forms; incorrect data; missing 
documentation. 

 

Finally Closed PO Hold (FINAL MATCHING) 

Invoice is imaged, but can’t be matched to the referenced PO that is “Finally Closed”. The Hold is 
not viewable in MarkView.  Accounts Payable clerk e-mails PO creator personally for appropriate 

account combination to charge.  PO creator replies via e-mail.  Accounts Payable processes invoice 

as a C-368 form. 
 

Items Not Ordered Hold (ITEMS NOT ORDERED HOLD) 

Items billed on invoice, but not ordered on PO 
 

Maximum Shipment Hold (MAX SHIPMENT) 

Total invoice line > total PO line by $25 
 

Quantity Ordered Hold (QTY ORD) 
Quantity billed on invoice > 10% of quantity ordered on PO 
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Glossary of Terms (continued) 

 
Quantity Received Hold (QTY REC) 

Created when any invoice is received for a PO that exceeds $5,000 and no receipt has been entered 

in BEN Financials for items invoiced 
 

C-Form Buckslip 
This is the Mark-up Accounts Payable will affix for C-forms that cannot be processed after they have 

been scanned, for example, missing documentation, an invalid, incorrect or frozen account. 
 

PO Buckslip Hold 

A hold placed on an invoice by Accounts Payable when an insufficient explanation is given on a Hold 
Resolution Sticky Note. 

 
Homepage 

 The BEN Financials Homepage provides a customizable point of entry into Ben Financials. 
 

Image 

 An online copy of an invoice or a C-368 form that has been scanned by Accounts Payable. 
 

Item Description 

A detailed description of an item, service or repair. 
 

Mark-Up 
Refers to the placement of electronically annotated objects (stamps or sticky notes) on an imaged 

document. 
 

MarkView 

Imaging system provided by a third-party supplier and is integrated with BEN Pays function. 
 

Menu  
A list that appears in a bar across the top of a window that consists of commands or actions you            

can perform. 

 
Plug-Ins 

Software programs that extend the capabilities of the Netscape Browser in a specific way.  J-Initiator 
and MarkView are software plug-ins that work with the web browser to run graphical BEN applications 

on a Windows PC or a Macintosh running Virtual PC.  J-Initiator must be installed before the MarkView 
plug-in is installed. 

 

PO Creator 
The individual who originated the PO (Buyer) who is responsible for reviewing and responding to all POs 

placed on hold. 
 

PO Manager 

Person who has been given authority to purchase goods and services on behalf of the University. The 
PO Manager has the authority to create a requisition and approve a requisition thus generating a 

Purchase Order which will be sent via EDI, fax, or US mail. 
 

Purchase Order (PO) 
Document sent electronically or via fax to the supplier to fulfill your requisition. Each Purchase Order is 

given a unique number and is an agreement from the University to the supplier that funds have been 

encumbered for the purpose of acquiring the specified goods and services from that supplier. 
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Glossary of Terms (continued)  
 
Receipt 

Electronic document created by the Requisition Creator for items received or services performed in a 

satisfactory manner. 
 

1. Goods received as requested - Positive receipt of goods and services is required by the 
Requisition Creator for all purchase orders valued at $5,000 or greater. Positive receipt of goods 

and services is required regardless of the purchase value if “Receipt Required” is activated. 
 

2. Damaged goods - The designated receiving agent (Requisition Creator) is responsible for 

notifying the supplier and the freight transport company immediately upon the discovery of 
damaged goods, and notifying the Accounts Payable Department in any instance where goods or 

services are discovered to be in less than satisfactory condition or are not in accordance with the 
terms of the purchase order.  

 

Receipt Quantity  
The quantity of items or services received in a satisfactory condition from a supplier. The supplier may 

ship the total quantity you requested in several shipments. In such cases, the receipt quantity will not 
equal the total quantity you requested until the final shipment is received and receipted.  

 
Record 

A record is one occurrence of data stored in all the fields of a block, also referred to as a row. 

 
Region 

A collection of related fields set apart from other fields within a block. Regions help to organize a 
 block so that it is easier to understand. 

 

Requisition 

An electronic request created by the system when a user saves the contents of a BEN Buys shopping 

cart which can hold items from the Penn Marketplace and/or non-catalog requests. The 
requisition is the document from which purchase orders are created.  A single requisition may result in 

multiple purchase orders. 
 

Scroll Bar  

A vertical or horizontal bar that appears on a window whose contents are not entirely visible. Click on 
the arrows, or drag on the box of a scroll bar to scroll through the hidden contents, or click in the bar 

itself to move to either the previous or next page.  
 

Supplier 
A company or individual that provides a product or service to the University in exchange for money. 

Replaces the term "vendor". 

 
Toolbar 

The toolbar is a collection of function buttons.  Each toolbar button replicates a commonly-used 
 menu item.  Depending on the context of the current field or window, a toolbar button will be either 

 enabled or disabled. 
 

View Manager 

The View Manager lists all of the Mark-up Views that have been previously created on a document. By 
clicking on the [I] icon, you will see all the views available for viewing the document. 

 
Window/Form  

 Replaces the word ‘screen’ and used interchangeably throughout BEN Financials. 
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Logging on to BEN Financials   
 
From the U@Penn Portal Business Tab (http://medley.isc-seo.upenn.edu/penn_portal/u@penn.php)  

 Click on BEN Financials>BEN Financials Homepage or type  http://benapps.isc-seo.upenn.edu/  

 These are websites you may want to create a “bookmark” or “favorite” in your web browser 

 
Included on this page is the following information: 

Across the Top 

 Contacts – takes you to information regarding BEN Helps and links to the Local Support Providers,  
Frequently Asked Questions, and the Financial Training Department 

 
 News – takes you to all the published communications regarding BEN 

 
 Related Links – takes you to the links for BEN Helps, Desktop Requirements and Setup, Hardware and 

Software Requirements, BEN Applications, Documentation, Training Information, Purchasing Services, 

Information Systems and Computing, Office of the Comptroller, and Office of the Vice President for 
Finance 

 

Along the Side 

 Access and Forms – takes you to the Document Forms Library which includes forms for BEN Reports, 
BEN Financials Printers, and Logon Request Forms 

 
 BEN Helps – takes you to the procedures for BEN Helps and includes a list of the 2 digit code for each 

School and Center 
 
 Desktop Requirements – takes you to the Hardware and Software requirements, installation of the J-

Initiator plug-ins for Internet Explorer and installation of MarkView Web Client 
 
 Documentation – takes you to the documentation for BEN Balances, BEN Buys and BEN Reports 

 
 FAQ – takes you to the ‘Frequently Asked Questions’ for all the BEN activities including BEN Helps, BEN 

Teaches, and General Usage 
 
 Training – takes you to the Financial Training Department homepage 

 
 Click on the BEN Financials link to login to BEN Financials 

Check here for 
important 

system 

availability 
messages 

 

http://medley.isc-seo.upenn.edu/penn_portal/u@penn.php
http://benapps.isc-seo.upenn.edu/
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BEN Financials Login Window 

 
 Enter your application User Name and Password 

 Click on [Connect] or press [Enter] 

 You will see the message below if you enter an incorrect password or if you attempt to login when 
the system is unavailable (e.g. after 8:00 p.m. EST on weekdays). 

 

 If you forget your password, go to: 

Customer Service 

3401 Walnut Street, Suite 265B 

215-898-1099   

 Requires Penn ID 
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BEN Financials Homepage 
 

 

 When you click any one of the Responsibilities the system displays the navigation paths in the right 

panel for the selected responsibility. 

 Click on any of the responsibilities listed in the left panel and the navigation path for the responsibility 
automatically changes in the right panel. 

 

 

 The Navigator window appears on the screen.  To change a navigation path within a responsibility, 

invoke the Navigator by  

 Closing all forms or  

 Clicking on the ‘Show 

Navigator’ icon on 

the toolbar  
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BEN Financials Responsibilities & Navigation Paths  

The BEN Financials Homepage lists the BEN Responsibilities for which you have access. Listed below each 

responsibility are the corresponding navigation paths. 

 

  
  

 
 

Senior Asset 
Administrator &  
Asset Administrator 
  

 Inquiry 

  Financial Transaction 

  Transaction History 
 Asset 

  Asset Workbench 
  Mass Changes 

 Other 
  Requests  

 Run 

 Invoice Inquiry 

 

 
 
Budget Entry (Secured)      
 Budget Journal 
 

Freeze Grant (Secured) 
 Freeze Grant 

 View Grant Attributes 
 View User 
  

Freeze/Unfreeze Grant 
 (Secured) 
 Freeze Grant 

 View Grant Attributes 

 View User 
  

 
 
 
 
 
 
 
 
 
 

GL Inquiry (Secured) 
 Notifications

 Inquiry 
  Account 

  Funds Available 

  Journal 
  Rev/Exp Inquiry 

 Acct Mapping 
 Legacy GL to BEN 

 Legacy SL to BEN 
 Legacy Subcode to 

  BEN Object 

 Legacy Account Desc 
 Legacy Subcode Desc 

COA Inquiry 
 COA Segment Values 

 View Grant Attributes 

Other 
  Profile 

 View User 
 

GL Reporting (Secured) 
 Reporting 
  Run Report 

  Create Report Set 
 Other 

  Profile 
 

Journal Entry – General 
 Notifications 

 Journals 

  Enter 
  Encumbrance 

 COA Inquiry 
 COA Segment Values 

 View Grant Attributes 

 Other  
  Profile 

View User 
 

 
 

 

 
 

 

 
 
PO Manager 
 Notifications 

 Purchase Orders 

  View/Control PO 
 Enter Receipts 

 Inquiry 
  Invoices 

  Locations 

  Receipts  
  Requisitions 

  Shipping Info 
  Suppliers 

 COA Inquiry  
  COA Segment Values

  View Grant Attributes 

 Reporting 
  Run Report 

  Create Report Set 
 Other  

 Profile 

 View User 

  
Requisitioner 
 Requisitions Homepage 

 Suppliers 

 PO Action History 
 Shipment Information 

  
User Preferences 
 General Preferences 

 
 

 

 
 

 

BEN Balances  

BEN Assets  BEN Buys  
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BEN Navigation – Typical Application Window 

Top of Window 
 BEN Financials Application Window Bar 

  Window/Form Name 

   Menu Bar  
    Toolbar 

 

Bottom of Window 
 Message Block 

Record # Block  

   Available Features Block 

 
Other Window Features 

 Yellow - shaded fields indicate required data field(s) 

 Gray - shaded fields indicate currently unavailable data field(s) 

 White – updatable but not required data field(s) 

 Blue – shaded fields indicate query mode  
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Switching Responsibilities  

To switch Responsibilities 

 Close the current form by either  

 Clicking on the ‘x’ in the upper right hand corner of the form or  

 Clicking on File>Close Form on the menu path or  

 Clicking on the ‘Close Form’ icon on the Toolbar 

 Once the forms are closed 

 Click on File>Switch Responsibility or  

 Click on the ‘Top Hat’ icon on the tool bar 

 This pop-up box will appear 

 

 

 
 
 
 
Taskbar  
 

 You can also go back and forth between Responsibilities by using the ‘Task Bar’ on your desktop  
 

 

 

     U@Penn Portal BEN Financials Homepage    Splash Screen        Application 
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Using the Applications 
Navigator Functions 
Region 

After selecting the 

Responsibility desired, the 
forms that you can navigate to 

are displayed in a navigation 
list on the left-hand side of the 

Navigator window. The 

navigation list is organized 
much like the hierarchy of a 

file system, where you can 
expand items that begin with a 

plus sign (+) to further sub-

levels until you find your form 
of interest. Sub-levels appear 

indented below the items from 
which they are expanded. 

Items that are expanded are 
preceded by a minus sign (-). 

You can expand no further 

when an item displays neither 
a plus or minus sign.  
 

Above the navigation list, you should see two fields that span the width of the window. These two fields help 

you identify your selection. The top field displays the name of the item currently selected, while the bottom field 
displays the choice highlighted. 
 

To expand or collapse the navigation list: 
 

 Choose one of the following methods to expand an expandable     item to its next sub-level: 

 Double-click on the item 

 Select the item and choose Open 
 Select the item and choose the Expand [+] button 

 

 Choose one of the following methods to collapse an expanded item: 

 Double-click on the item 
 Select the item and choose the Collapse [ - ] button 

 

 To expand or collapse several items at once, choose one of the following buttons: 

 Expand All Children--expand all the sub-levels of the  currently selected item 

 Expand All--expand all the sub-levels of all expandable items in the navigation list 
 Collapse All--collapses all currently expanded items in the navigation list 

 

 To open a form from the navigation list: 

 Select your form of interest 
 Choose Open 

 

 Alternatively, you can double-click directly on the form of interest to open it. 
 

 Do not double-click on the Open button.   All buttons require only a single click to activate. 
 
 

These are the 
options 
available from 
within the GL 
Inquiry 
responsibility 
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Using the Top Ten List 
 
If there are forms that you use frequently, you can copy them over to a navigation top ten list located on the 

right-hand side of the Application Functions Region Navigator. The top ten list displays your forms numerically 

so you can choose them instantly without having to drill down for them in the navigation list. You can add a 

maximum of ten forms to the top ten list and you can create a different top ten list for each responsibility you 

have access to. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To create a Navigation Top Ten List: 

 Highlight a frequently used form from the navigation list 

 Click on the arrow going right 

 The form now appears in the navigation top ten list preceded by a top ten list number 

 If you wish to remove a form from the top ten list, highlight the form in the top ten list and click on the 
arrow going left  
 

To open a form from the navigation top ten list: 

 Type the top ten list number that precedes the form you want to open 

 You can also highlight the form you want and click on [Open], or double-click on the form 

 The name and description of the form selected also appears in the current selection fields above the 
navigation list. 
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User Preferences (Optional) 
 

 From the BEN Financials Homepage, click on User Preferences to change your password 

 Users will be prompted to change their password every 30 days.  User Preference is used to change 
your password when desired. 
 

 Click on [Apply] 

 Click on  the             to return to the BEN Financials Homepage 
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Menu Paths 

 

Right Mouse Button Menus 
Depending on your desktop settings, using the right (or left) mouse button 

may allow you to access the following menu items:                           
 

 Cut 
 Copy 

 Paste  
 Folder Menu 

 Help 

 

Pull Down Menus 
 

 

Use the Pull Down menu bar to navigate through a form, to edit or retrieve data, or to perform various other 

actions. 
 

 Available functions show in black, while unavailable functions show as “grayed out”. 
 
File Menu 

 

The File menu lets you perform several actions in BEN Financials: 
 

 New  Opens a new record in the active form.  
 Open Opens the detail screen for the current selection.  

  Save Saves any pending changes in the active form.  
  Save and Proceed Saves any pending changes in the active form and advances to the next 

record.  

  Next Step Updates the Process workflow in the Navigator by advancing to the next 
step in the process.  

  Export Exports data retrieved.  
  Place on Navigator Creates an Icon in the Documents tab of the Navigator which can be used 

to recall the active form and its current record.  

  Log on as a Different User Exits the application and displays the BEN Financials Logon window.  
  Switch Responsibility  Displays the Applications Responsibility window.  

  Print   Prints your current window. An application may override this action to 
instead allow printing of one or more specific reports.  

 Close Form  Closes all windows of the current form.  
 Exit Oracle Applications Quits BEN Financials Applications. 
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Menu Paths (continued) 
 

Pull Down Menus (continued) 

 

 

 Available functions show in black, while unavailable functions show as “grayed out”. 
 

Edit Menu 

Use the Edit menu to edit your data in BEN Financials: 

Undo Typing Undo any typing done in a field before the field is exited and returns the 
field to the most recent value.  

 Cut  Cut the current selection to the clipboard.  

Copy Copy the current selection to the clipboard.  
 Paste Paste the contents of the clipboard into the current field.  

 Duplicate Record Above Copies all values from the prior record to the current record.  
  Duplicate Field Above Copies the value of the current field from the prior row.  

  Clear Record Erases the current record from the window.  

  Clear Field Clears the data from the current field.  
 Clear Block Erases all records from the current block.  

  Clear Form Erases any pending changes from the current form.  
  Delete Deletes the current record from the database.  

  Select All Selects all records (for blocks with multi-select).  
 Deselect All Deselects all selected records except for the current record (for blocks with 

multi-select).  

  Edit Field   Displays the Editor window for the current field.  
  Preferences Change Password Displays the Change Password dialog box.  

  Preferences Profiles Displays the Profiles window. 
  

View Menu 

The View menu provides you with the following options: 

 Show Navigator  Displays the Navigator window.  

 Zoom  Invokes custom defined zooms.  

 Find   Displays the Find window to retrieve records.  
 Find All  Retrieves all records.  

 Query by Example Enter  Invokes 'Enter Query' mode to enter search criteria for a 
                                  query-by-example.  

 Query by Example Run  Executes the query-by-example.  

 Query by Example Cancel  Cancels the query-by-example by exiting from 'Enter Query' 
mode.  

 Query by Example Show Last Criteria  Recovers the search criteria used in the previous query- by-
example.  

 Query by Example Count Matching Records Counts the number of records that would be retrieved if      
you ran the current query-by-example.  

 Record First  Moves the cursor to the first record.  

 Record Last  Moves the cursor to the last record.  
 Translations   Displays the Translations window.  

 Attachments   Displays the Attachments window.  
 Summary/Detail  Switch between the summary and detail views of a 

combination block.  

 Requests  Displays the Request window.  Requests are your reports. 
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Menu Paths (continued) 

 

Pull Down Menus (continued) 

  
 

 Available functions show in black, while unavailable functions show as “grayed out”. 
 

Folder Menu 

The Folder menu lets you customize the presentation of data in a folder: 

New Creates a new folder definition.  
Open  Opens an existing folder definition.  

Save (Do Not Use – Saves Query) Saves changes to the current folder definition.  
Save As (Use – Doesn’t Save Query) Saves current folder definition to a new name.  

Delete  Deletes an existing folder definition.  

Show Field  Displays a field that is currently hidden.  
Hide Field  Hides the current field.  

Move Right  Moves the current field to the right.  
Move Left  Moves the current field to the left.  

Move Up  Moves the current field up.  

Move Down  Moves the current field down.  
Widen Field  Increases the width of the current field.  

Shrink Field  Decreases the width of the current field.  
Change Prompt  Changes the prompt for the current field.  

Autosize All Adjusts all field widths to completely show their data.  
Sort Data  Specifies sort order for the first three fields by ascending, 

descending and no ordering.  

 View Query  Displays the query criteria for the current folder definition.  
 Reset Query  Erase the current query criteria.  

 Folder Tools   Display the folder tool palette.  
 

Tools Menu 

The functions in the Tools menu differ based on the area of Responsibility in which you are currently working.  
Available functions show in black, while unavailable functions show as “grayed out”. 

 

Window Menu 
The Window menu displays the names of all open application windows and window placement options. 

 

 Cascade Displays any open windows in a "cascaded" or stair-stepped 
fashion. 

 Tile Horizontally Displays any open windows in a horizontally "tiled" 
  (non-overlapping) fashion. 

 Tile Vertically Displays any open windows in a vertically "tiled"  

(non-overlapping) fashion. 
 Open Window List  Displays a list of open window titles in the order in which they are 

stacked.  
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Menu Paths (continued) 

 

Pull Down Menus (continued) 

 

 

 Available functions show in black, while unavailable functions show as “grayed out”. 
 
Help Menu 

Use the Help menu to get additional information about BEN Financials: 

Window Help  Displays help for the current window.  
Oracle Applications Library   Displays a window that lists all available Oracle Applications help 

text.  
Keyboard Help   Displays the current key mappings of specific functions and menu 

options. 
Diagnostics  Used for technical diagnostics.  

Record History  Displays information about the current record.  

About Oracle Applications   Displays information about the current window and application, 
including version information.  
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Toolbar  
 

 
 
Collection of iconic buttons replicating commonly-used menu selections. Depending on the context of the 
current field or window, a toolbar button will be either enabled or disabled. You can display the label for an 

enabled toolbar button by holding your mouse over the button. The toolbar buttons and the actions they 

perform are as follows: 
 

New - Opens a new record in the active form.  

Find - Displays the Find window to retrieve records.  

Show Navigator – Displays the Navigator window. 

Save - Saves any pending changes in the active form.  

Next Step - Disabled in BEN Financials. 

         Top Hat – Enables switching Responsibilities.  

Print - Prints the current screen that the cursor is in, i.e. the ‘print screen’ function. 

Close Form - Closes all windows of the current form.  

Cut - Cut the current selection to the clipboard.  

Copy - Copies current selection to the clipboard.  

Paste - Pastes from the clipboard into the current field.  

Clear Record - Erases the current record from the window.  

Delete – Deletes the current record from the database. 

          Edit Field - Displays the Editor window for the current field.  

           Zoom – Get Next Invoice Image (typically used by Accounts Payable)  

 Translations - Invokes the Translations window.  

 Attachments - Invokes the Attachments window. If one or more attachments already 

 exist, the icon changes to a paper clip on a piece of paper.  

Folder Tools - Displays the folder tool palette.  

Window Help - Displays help for the current window. 
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Keyboard Shortcuts 
 

Although these functions can be accessed either by the toolbar or pull down menus, Keyboard Shortcuts are yet 

another option for navigating through BEN. 
   

Block menu  [Ctrl] [B] 

Clear Block [F7] 

Clear Field [F5] 

Clear Form   [F8] 
Clear Record [F6] 

Commit [Ctrl] [S] 

Count Query [F12] 

Delete Record [Ctrl] Up Arrow 

Display Error [Shift] [Ctrl] [E] 

Duplicate Field [Shift] [F5] 

Duplicate Record [Shift] [F6] 

Edit [Ctrl] [E] 

Enter Query [F11] 

Execute Query [Ctrl] [F11] 

Exit [F4] 

Help [Ctrl] [H] 

Insert Record [Ctrl] Down Arrow 

List of Values [Ctrl] [L] 

List Tab Pages [F2] 

Next Block [Shift] [Page Down] 

Next Field [Tab] 

Next Primary Key [Shift] [F7] 

Next Record Down Arrow 

Next Set of Records [Shift] [F8] 

Previous Block [Shift] [Page Up] 

Previous Field [Shift] [Tab] 

Previous Record Up Arrow 

Print [Ctrl] [P] 

Return [Enter] 

Scroll Down [Page Down] 

Scroll Up [Page Up] 

Show Keys [Ctrl] [K] 

Update Record [Ctrl] [U] 
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Navigation Tips  

Item BEN Financials 
 

Navigating Pull Down Menu Paths; Toolbar icons; Keyboard shortcuts 

 
Quickpick List of Value icon [···] within field or [Ctrl] L 

 
Cancel Runaway Query Pop-up box appears after first 100 records.  Click [Continue], [Stop] or 

[Continue to End] or Click [Cancel] on ‘Press Cancel…’ message. 
  

Change Responsibility File>Switch Responsibility or clidk on Tophat icon 

 
Move From Fields and Zones  [Tab] or Move Cursor With Mouse 

 
Finding Patterns With Wildcards You can use the percent '%' wildcard within a field to represent any 

 number of characters (including no characters). 

 
 Example: To retrieve all records that contain the word "Central" in a 

 specific field, you would enter %Central% in that field. Click [Find]. 
 

Case Sensitive? Yes 
 

Message and Status Lines Bottom of Window 

 
Available Options Toolbars & Menu Items 

 
Record History Help>Record History  

 

Name in Action History View User option listed under various Responsibilities 
 

Enter Query View>Query By Example>Enter  or [F11] or Flashlight Icon 
 

Execute Query View>Query By Example>Run or [Ctrl] F11 or click [Find] 
 

Cancel Query View>Query By Example>Cancel of [F4] 

 
Copy Field Edit>Duplicate>Field Above or [Shift] [F5] 

 
Copy Record Edit>Duplicate>Record Above or [Shift] [F6] 

 

Paste Edit>Paste 
 

Error Message Pop-up Box 
 

Report Requests 
 

Additional Record Information Pop-up List or […] 

 
Insert Row [Ctrl] Down Arrow or NEW record icon 

 
Field Edit Edit>Edit Field 

 

Exiting File>Exit Oracle Applications 
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Additional Tips 

Canceling a Long Running Query  

 
When a query may take longer than a few seconds to retrieve the selected records, this pop-up message may 

appear.  Ignore this message if you wish to wait for the query to finish.  Or click on [Cancel] to end the query 
and either enter data to narrow the search or re-enter any mistyped information. 

 

 

Canceling a Query with Many Records 
 
If you enter a query and the records exceed 100, you will see this message appear.  Select from the following 

options: 

 [Continue] - will continue to the next 100 records 

 [Stop] - will stop the query 

 [Continue to End] - will continue to the end of the entire query 

 

Server Not Available 
 
The pop-up box below will appear when a server connection is unavailable, e.g. due to hardware or network 

problems.  Click [OK] to remove message. 
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Exporting BEN Financials Data to a Microsoft Excel Spreadsheet 
 

Procedure 

 From the menu, click on File>Export 

 If your desktop is configured properly, you should either see the spreadsheet or the following box, which 

should say Opening: filename using EXCEL.EXE.  If it does not say EXCEL.EXE, your desktop is not 

configured properly (see below). 

 

 

 

 

 

 

 

 

 

 

 

 

 Select Open It and click [OK] 

 

Desktop Configuration 

 Should be handled by your Local Support Provider (LSP) 

 Do-it-yourself instructions can be found here: 

http://www.finance.upenn.edu/ben/benfin/desktop_req/config-excel.shtml  

 If your desktop is not configured properly, you will receive the following box.  You can either select 
Pick App… and browse to the EXCEL.EXE file on your hard drive, or select Save File… and open the file 
from within Excel later. 

 

 

 

 

 

 

http://www.finance.upenn.edu/ben/benfin/desktop_req/config-excel.shtml
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Using the Navigator's Documents Region 
 
If you have a document, such as a particular purchase order, invoice, or report that you want to access later, 

you can create a link to the document using the Navigator's Document feature. The Navigator's Document 

feature allows you to create as many links as you want and save them in the Documents region of the 
Navigator window. The links can be represented as icons in the window or may be viewed as a list. When you 

use a link to open a document, BEN Financials opens the document in the appropriate form window. You can 
access the Document region using the tab titled ‘Documents’.  

Adding New Documents to the Navigator 

 Forms that support adding documents to the Navigator enable the Place on Navigator menu item in the 

File menu.  Use this menu item to add your document to the Navigator. 

Opening the Navigator's Document Region 

 Click on the Documents tab in the Navigator window 

To Open a Form from the Document Region 

 Select the document link you want to open 

 Click on [Open] or double-click on it  

Renaming Documents in the Navigator 

 Highlight the document link you want to rename. 

 Click on [Rename] or double-click on the label 

 Enter the new name, then 

click [OK] 

 There is a limit of 80 
characters for document 
names 

 

Removing Documents from 
the Navigator 

 

 Highlight the document link 
to be discarded 

 

 Click on [Remove] 

 Documents placed on 
the Navigator will stay 
there until you remove 
them. 

Removing the document 

link from the Navigator has 

no effect on the actual document. However, if a record such as a report request is deleted, the link 

in your Navigator displays a message letting you know that your link is now invalid.  

Label 

 Once you create a link 
to a document, the 

Document region will open 

by default when you log on.  
Information here is 

static, i.e. not updated. 
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Logging Off of BEN Financials 
 
When you are ready to logoff of BEN Financials 
 

 Close all the open windows and forms by clicking on the ‘x’ in the upper right hand side 

 Click on File>Exit Oracle Applications 

 Click [OK] 
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Invoice Inquiry 
 
You can find invoices to respond to supplier inquiries, including questions regarding invoice payment status, 

check clearance status, invoice payment date, reasons an invoice has not been paid, how much of a purchase 

order has been receipted, and total balance due for a supplier or supplier site.  
 

In the Find Invoices window, you can enter a variety of criteria, including invoice status and ranges for invoice 
amounts and invoice dates. You then choose Find to navigate to the Invoices window, where BEN displays all 

invoices that match your search criteria.  
 

From the Invoices window, you can navigate to other windows to review scheduled payments, distribution 

holds, related payments, and more. 
 

 
To find an invoice using the Find Invoices window select the Invoice Inquiry responsibility from the BEN 

Financials Homepage.   

 

 Click on Inquiry>Invoices navigational path 

 

 Click on [Open] or double click on Invoices 
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Invoices (continued) 
 

 Enter search criteria using one field or a combination of fields.  For example you 

can use:  
 

1) PO # or  

2) Supplier and Invoice # or  
3) Supplier and amount range 

 

 The Invoices form opens  

 Note the paperclip with the piece of paper on the toolbar 

 To review an image of the invoice, click on the Attachments  icon on the Toolbar to invoke 
MarkView 

software. Accounts 
Payable creates an 

electronic image of 

supplier invoices 
and C-368 forms 

and the attached 
invoice. Items not 

imaged include: C-

1, C-1A, and C-368 
forms (when used 

for travel 
purposes), petty 

cash 
reimbursement 

requests and 

supporting 
document 

(contracts, 
competitive bids) 

for Purchase 

Orders. 

Tip: It is not 

recommended that 
you use Supplier as 

the only search 

criteria 
 

Tip: Good idea to use 

wildcards (%) when 
searching using the 

Invoice # 
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Invoices (continued) 
 
 Enter your BEN Financials User name and Password to 

retrieve the invoice 

 View the invoice below  

  

  

  

  

 

 For more information regarding ‘Invoice Images’ see the ‘Accounts Payable Invoice Imaging User Guide’ 
http://www.finance.upenn.edu/ftd/documentation/benpays.pdf  

 

 

 

 

 

http://www.finance.upenn.edu/ftd/documentation/benpays.pdf
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 Invoices (continued) 
 

 In order to view the PO from the Invoice Inquiry menu path, click on [Overview]  
 
 

 

 
 

 
 

 
 

 

 
 

 
 

 

 
 

 
 

 
 

 

 
 

 
 

 Click on [View PO] 
 

 

[Invoices] takes you back 
to Invoices form above 

 

Click [Distributions] 

to go to account 
information for this PO 
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Invoices (continued) 
 
Viewing Quantity Detail  
 

 

 

 

 

 

1. Quantity - is the number of item(s) or amount of the Purchase Order 

2. Quantity Billed - is the number of item(s) or amount of the invoice sent to Accounts Payable by the 

supplier 

3. Quantity Received - is the number of item(s) or amount that has been receipted by Penn  

 If the Quantity and/or the Quantity Received does not ‘match’ the Quantity Billed according to the 

established criteria, the invoice will go on Hold.   

 See the BEN Buys Accounts Payable Invoice Imaging User Guide regarding managing 

invoices placed on ‘Hold’ 

 In this example the quantity ordered is greater than the quantity billed.   However, since the quantity 

received equals the quantity billed Accounts Payable will automatically pay this invoice for the amount 

billed/received. 

 Additional payments can be made from this PO if the PO is not ‘finally closed’ by Accounts Payable. 

 See the PO Manager User Guide for information on how to request a ‘Final Close’ on a Purchase 

Order.  

 Click [Distributions] to go to account information for this PO 

2 

3 

1 

1 

2 

2 

3 

1 
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Invoices (continued)    
 
The Invoices form will list all invoices charged against the specified purchase order.  Your first indication as to 
whether or not a payment was processed is the Amount Paid field.  If no payment is reflected in this field the 

invoice may have been placed on ‘Hold’.   

Holds 

 

The Holds field will indicate the number of holds against a particular invoice.  Click on the Holds tab to 

ascertain the type(s) of hold against the invoice. 

 
 

 
 

 

 
 

 
 

 
 

 

 
 

 
 

 

 
 

 
 

 
 

 

 
 

 For more information regarding ‘Holds’ see the ‘Accounts Payable Invoice Imaging User Guide’ 
http://www.finance.upenn.edu/ftd/documentation/benpays.pdf  

Holds 
Tab 

http://www.finance.upenn.edu/ftd/documentation/benpays.pdf
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 Invoices (continued) 

PO Hold Resolutions Grid  

 

 
 

 For more information regarding ‘Holds’ see the  “Invoice Imaging User Guide’ 
http://www.finance.upenn.edu/ftd/documentation/benpays.pdf  

 
 

Hold Resolution Grid 

Hold Type Approve Invoice Cancel Invoice 

Quantity Ordered Hold 
(Qty Ord) 

Apply Holds Resolved stamp 

Apply Return to Accounts 
Payable stamp with the 
reason for cancellation in the 
comment box 

 

 

Maximum Shipment 
Hold  
(Max Ship Amount) 

Apply Holds Resolved stamp 

Quantity Receipt Hold 
(Qty Rec) 

Log on to BEN Financials and process 
receipts via Requisitioner or PO Manager 
Responsibility 

Multiple Holds  

(e.g. Max Ship Amount 
& Qty Rec) 

Apply Holds Resolved stamp.  If one of 
the holds is a QTY REC Hold, log on to 
BEN Financials and process receipts via 
Requisitioner or PO Manager 
Responsibility 

Comment Requested 
(170_SYSTEMS_HOLD) 

Review message sent by Accounts Payable by clicking on Comment 
Requested Markup & apply Return To stamp with info requested 

http://www.finance.upenn.edu/ftd/documentation/benpays.pdf
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Invoices (continued)  

View Payments  
 

If a payment has been processed click on the Payment Tab to access detailed payment information, such as 

the payment method, check/document number and payment date, etc. 
 

 Note: Payment Terms - Checks are produced based upon the payment terms that are 
assigned to the supplier.  
 

a. Employees are created with terms of ”Net 2" which means that a check will be generated 

two days after the invoice date that is entered in 

the Accounts Payable system when the particular 
form is processed.  

b. Most suppliers are created with payment terms of 
“Net 30" which means the payment will be made 30 

days AFTER the invoice date.  However, some 

suppliers have a payment term of immediate due to a prompt pay discount offer with the 
supplier. 

 
 

 

 Click on [Payment Overview]  

View 
Payments 
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Invoices (continued) 
 

View Payments (continued) 
 

 The Payment Overview form has more information about the check, Supplier address and Bank 
 

 

 Click on [Payments] for more information regarding the payment  

Date check 
cashed appears 

here when 
Supplier cashes 
check 

List of all 

invoices paid on 

check 
 

Supplier address 
where check is 

mailed 

 

University’s 

bank 
information 
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Invoices (continued) 

View Credit Memos w/Image 

 

 Below is a sample of a credit memo with the corresponding invoice image in the Invoices form 
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Invoices (continued) 

Sample Cancelled Check 
 

 Below is a sample of how a ‘cancelled’ check appears in the Invoices form 
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Invoices (continued) 

Sample Cancelled and Reissued Check 
 

 Below is a sample of how a ‘cancelled’ and ‘reissued’ check appears in the Invoices form 
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Suppliers 

Supplier List Query 

 

 From the Navigator, double click on Suppliers 

 Enter a search criteria 

 Click on [Search] to execute the query  

 

 
 

 
 

 
 

 
 
 
 

 
 

 

 
 

 
 

 

 
 

 
The list of suppliers matching your search criteria will be returned. 

 

 
 

 

Field is case 
sensitive. Use caps 
when ‘Match Case’ 

is checked. 

Click on the drop-
down for additional 

ways to search 

Address where 
payment is sent is 

located here Fax where PO is 
sent is located here 
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Shipment Information 
 

 From the Navigator, double click on Shipment Information 

 Enter a search criteria 

 Click on [Search] to execute the query  

 

 
 To see the name and phone number of the person responsible for the order, click on [Contact Info]  

 

 To see the street address of where the order will be delivered, click on [Ship-to info] 
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Appendix A:  

Viewing and Creating Folders 
 
A folder block is a special block whose field and record layout you can customize. The following helps you 

distinguish a folder block from a regular block: 
 

           

 An enabled Folder 
menu appears in the 
main menu bar when 

your cursor is in a folder 
block. 

 

 An Open Folder icon 
appears in the upper left 

hand corner of the form.  

 

 An enabled Folders 
Tool icon appears on 

the toolbar when your 
cursor is in a folder 

block. 

 
 

 

Clicking on the Folders Tool  icon will open the Folders Tools box. 

 
Your Folders Tool options are as follows: 

 
 

 

 
 

 
 

 

 
 

 
 

 
 

 

 
 

 
 

(From left to 
Right) 
Open 
Save 

New 
Delete 

 

(From left to right) 
Widen Field 
Shrink Field 

Show Field 

Hide Field 
 

Arrows allow you 

to move a 
selected column 
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Viewing and Creating Folders (continued) 

Viewing Existing Folders 

Before you attempt to create a new folder, check to see what folder options are available to you by clicking on 

the Open Folder icon in the upper left corner of the form.  If you have made the decision to utilize an existing 
folder, select Folder>Save As on the menu path.  Once the Save Folder form becomes available to you, 

select the Open as Default option and click on [OK].  

 

Creating a Folder and Changing Your Default  
 

Place your cursor in the column you want to adjust and select one of the options listed above or hover over the 

column header and your cursor will change into           which indicates that you are able to move the column or           

which denotes you can adjust the width of the column.  

 

Once you have completed all of your alterations, save your changes by using the Folder>Save As menu path. 
 

 Never save your changes by using the Folder>Save menu path or the Disk icon.  You performed a 
query to access the form you have altered.  This method of saving will capture the alterations you have 
made along with the query you utilized to get to that particular form and will prohibit you from retrieving 
information on future queries. 

 

The Save Folder form will appear. 

 

Column 

Heading 
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Viewing and Creating Folders (continued) 

Creating a Folder and Changing Your Default (continued) 

 Select Open as Default 

 Unselect Public 

 Click [OK] 
 
BEN Financials will confirm that you want to save your private folder. 

 

 
 

 Click [OK] 
 

Creating a Folder Without Changing Your Default 
 

Place your cursor in the column you want to adjust and select one of the options listed above. 
 

Once you have completed all of your alterations, save your changes by using the Folder>Save As menu path. 
 

The Save Folder form will appear. 

 

 
 

 Unselect Public 

 Click [OK] 
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Viewing and Creating Folders (continued) 
 

Creating a Folder Without Changing Your Defaults (Continued) 
 

BEN Financials will confirm that you want to save your private folder. 
 

 
 

 Click [OK] 
 
Whenever you perform an inquiry on the form that you have altered you will be required to select your default 

folder by selecting from the menu path Folder>Open.   

 
The Open Folder form will appear. 

 

 Select the appropriate folder 

 Click [OK] 
 

 Note the BEN Financial default folder has the owner name of POADMIN. 
 

Deleting a Folder 

While your cursor is resting on the form in which you created a folder select from the menu path Folder>Delete 

or invoke your Folder Tools box by clicking on the Folders Tool  icon and clicking on the Delete  icon. 
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