Desktop Requirements

Consistent with Information Systems and Computing's recommendations for accessing Penn's central administrative systems, these are the desktop configurations for BEN Financials. Consult your Local Support Provider if you have questions or need assistance installing the software.

To see a consolidated PDF matrix of Desktop Requirements for both Windows & macOS please click here, otherwise all details are shown below.

Windows 7, 8 and 10

  • Windows 7, 8 and 10 are the only version of Windows certified (32-bit & 64-bit for all versions).

  • Recommended Configuration: Desktop Standard

  • Recommended Web Browsers (32-bit & 64-bit for all versions):
  • Internet Explorer 11.0
  • Firefox Quantum ESR 60.x
  • Chrome (see Note below)
  • Microsoft Edge (see Note below)

NOTE: If launching Java-based forms in BEN Financials, while Chrome & Microsoft Edge can be used, they do not offer the option to remember preferences and the user will need to repeat the security question & downloads each time the forms are launched. This is expected behavior as a result of web browser limitations.


  • Client Software:
    • BEN Financials and BEN Pays Invoice Imaging: Java 1.8 Update 151 will be the lowest version of JRE that will be supported for use with BEN Financials.
    • BEN Requisitions and Penn Marketplace: Java is NOT required for end users who have access ONLY to the Requisitioner responsibility (i.e., to shop in the Penn Marketplace)
    • BEN Pays Invoice Imaging: Invoice imaging browser based viewer requires Flash Player. The vendor supports Adobe Flash Player version 10 and above for use with the MarkView viewer, provided that the version is supported by Adobe for the operating system and browser version in use.
    • Users that have access to Oracle Web ADI for uploading journals or maintaining TEM/Concur data can use Office 2010, 2013 or 2016. In order for the ‘Add-In > Oracle’ tab to display in Excel, users with Office 2013 may need to clear browser and Java cache and delete temporary internet files prior to using Office 2013 for the first time with Web ADI.
    • Further details on Java Web Start for BEN Financials are located here.


     

Mac OS 10.x

Requirements for BEN Financials and BEN Pays Invoice Imaging: To use BEN Pays, BEN Balances, and/or the full complement of BEN Buys capabilities, you will need this configuration:

  • If user has macOS Mojave 10.14.1 or higher, then browser & JRE versions are:
    • FF ESR 60.x
    • JRE 8 (1.8.0_191 and higher)
    • NOTE: Running Java content using Java Web Start downloads a *.jnlp file into the specified browser downloads folder. These are not removed automatically when running this version of JRE on macOS. To have the files removed automatically, upgrade to JRE 8 (1.8.0_192 and higher).
  • If user has macOS High Sierra 10.13.3 or higher, then browser & JRE versions are:
    • FF ESR 60.x
    • JRE 8 (1.8.0_171 and higher)
    • NOTE: Running Java content using Java Web Start downloads a *.jnlp file into the specified browser downloads folder. These are not removed automatically when running this version of JRE on macOS. To have the files removed automatically, upgrade to JRE 8 (1.8.0_192 and higher).

  • Minimum Recommended Configuration: Desktop Standard


     

Windows and Macintosh: Additional Information

For additional information on desktop standards or if you are purchasing a new system, consult your local support provider (LSP) or refer to the Desktop standards.