Desktop Requirements

Consistent with Information Systems and Computing's recommendations for accessing Penn's central administrative systems, these are the desktop configurations for BEN Financials. Consult your Local Support Provider if you have questions or need assistance installing the software.

Windows 7 and 8

  • Windows 7 and 8 are the only version of Windows certified.

  • Recommended Configuration: Desktop Standard

  • Web Browser:Internet Explorer 11.0 (32 bit version) and Firefox 52 ESR (32 bit version) through the current version

    NOTE: In order for IE 11 to work with BEN Financials. ‘upenn.edu’ must be added to the Compatibility View (Tools > Compatibility View settings).

    NOTE: Planning users will not be able to access Planning using IE 11. Browser recommendations for Planning is located here: Office of Budget and Management Analysis


  • Client Software:
    • BEN Financials and BEN Pays Invoice Imaging: Java 1.8 Update 151 will be the lowest version of JRE that will be supported for use with BEN Financials (All updates higher than 151 are expected to work but have not been formally certified. Please ensure that the Java is the "32-bit version" and not the "64-bit version", so that the Java matches the web browser's "32-bit" version).
    • BEN Requisitions and Penn Marketplace: Java is NOT required for end users who have access ONLY to the Requisitioner responsibility (i.e., to shop in the Penn Marketplace)
    • BEN Pays Invoice Imaging: Invoice imaging browser based viewer requires Flash Player. The vendor supports Adobe Flash Player version 10 and above for use with the MarkView viewer, provided that the version is supported by Adobe for the operating system and browser version in use.
    • Users that have access to Oracle Web ADI for uploading journals or maintaining TEM/Concur data can use Office 2010 or Office 2013. In order for the ‘Add-In > Oracle’ tab to display in Excel, users with Office 2013 may need to clear browser and Java cache and delete temporary internet files prior to using Office 2013 for the first time with Web ADI.
    • Further details on JRE installation for BEN Financial are located here.


  • Display:
    • 1024 x 768 or above resolution
    • 17-inch or larger monitor recommended, but not required

 

Mac OS 10.x

Requirements for BEN Financials and BEN Pays Invoice Imaging: To use BEN Pays, BEN Balances, and/or the full complement of BEN Buys capabilities, you will need this configuration:

  • Intel-based Mac with Mac OS 10.7.x, 10.8.x, 10.9.x

  • Minimum Recommended Configuration: Desktop Standard

  • OS X Lion (10.7), Mountain Lion (10.8), and Mavericks (10.9) are certified by Oracle

  • Web Browser: Safari 6.2.x, 7.1.x, 8.0.x, 9.0.x


  • Client Software:
    • BEN Financials and BEN Pays Invoice Imaging: Java 1.8 Update 151 will be the lowest version of JRE that will be supported for use with BEN Financials (All updates higher than 151 are expected to work but have not been formally certified. Please ensure that the Java is the "32-bit version" and not the "64-bit version", so that the Java matches the web browser's "32-bit" version).
    • Users that have access to Oracle Web ADI for uploading journals or maintaining TEM/Concur data can use Office 2010 or Office 2013. In order for the ‘Add-In > Oracle’ tab to display in Excel, users with Office 2013 may need to clear browser and Java cache and delete temporary internet files prior to using Office 2013 for the first time with Web ADI.

  • Display:
    • 1024x768 or above resolution

 

Windows and Macintosh: Additional Information

For additional information on desktop standards or if you are purchasing a new system, consult your local support provider (LSP) or refer to the Desktop standards.